Node.js SyntaxError: unexpected token “…”(点点点)のエラーになる件

こんなエラーが出た

Node.js SyntaxError: unexpected token “…”

どうもこの原因は簡単で、

ES6/Node.jsの新しいバージョンで対応された spread operationという機能がない見たいらしい

すなわち、Node.jsが古いのでバージョンあげてねって話.

まず npmでnをインストール

sudo npm install -g n

nで適切なnodeバージョンをインストール

n 8.6.0

下記二つによればnode 8.6とか入れとけ安牌っぽい? (8.3から対応しているみたい)

https://stackoverflow.com/questions/40066731/node-v6-failing-on-object-spread

https://stackoverflow.com/questions/36666433/node-5-10-spread-operator-not-working

About the author

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です